【Home】   【日記メニュー】

IE7で検索エンジンをGoogleにするとGoogle検索が出来ない。使えない。

●2008/08/15
テスト機で使ってるブラウザ(Windows Vista IE7)で標準の検索エンジンをGoogleに設定してあったが、ある日突然このGoogleを既定にセットしてあると検索が出来ない事に気がついた。それだけならまだしも、壁のIEのアイコンをクリックしてネットを始めようとしたら、ブラウザが表示するまでにめちゃ時間が掛かる。

それだけなら待てばええけど、最後には「IEではこのページを表示出来ません」が出る。 なんだぁ〜〜〜あ!!!


【症状】
何が原因かはいまだに不明やけども

Vista IE7 でgoogle検索が使えない。検索中のままになってなかなか表示しないほぼハング状態。そのまま待ってみても
最後には「IEではこのページを表示出来ません」が出る始末。

(これをクリックするとなかなか表示しません。こんな感じになるとゆうサンプルですからクリックは覚悟してしてね。
ただし、中断すると速攻で戻ります。)


原因は不明。なぜだか知らないけどVISTA(IE7)で標準の検索エンジンをGoogleにしてるとこんな問題が起きた

●ブラウザ(IE7)をクリックして起動させるとスタートサイトがいつまで経っても表示されない。やがてIEではこのページを表示できませんを出してしまう。
●しかし起動時に検索エンジンをGoogleのままでお気に入りのURLをクリックするとなぜかそのページは表示する。
●標準の検索を Live Search からGoogleに変更してると検索窓で検索できない。いつまで経っても検索中のままになる。


【対策】
やった事と言えば、原因が不明やから対策のしようがない。そこで仕方がないで次の事をやってみた。
●試しに検索エンジンを MS標準の Live Search にして試してみた。
参考画像(2)
すると、IEの起動もすんなりと素早く起動するし、また検索窓に検索語を入れても瞬時に検索結果を表示する。
こうなると、悪いのはGoogleを使うと問題が起きると言うのがわかった。

●追加プロバイダの検索を出して、既定にしてあったGoogleを一旦削除して再度選んで再登録してみた。

既定にしてあったGoogleにカーソルを当てて反転させてから「削除」をクリックして削除。

その後、もう一度Googleを選んで登録
1:参考画像(1)の部分で「追加プロバイダの検索」をクリックして追加の画面を出した。

(クリックすると大きな画面になります)
Googleを選んで再度既定に設定で登録して、IEを閉じて壁のアイコンをクリックして起動して試してみた。
やっぱし、同じ症状になる。
(すると、ここに登録されているGoogleの設定に問題があると判断した)

●この「追加プロバイダの検索」では無くて自分でGoogleを登録してみようと思った。次のようにした。
1:上の参考図の黄色い部分に登録したいURLを書いて表示したい名前を決めて「インストール」をクリックすると自分で検索エンジンを登録する事が出来る。

ただし、登録の仕方がなぜか、検索エンジンので大文字で「TEST」と入力して、その検索結果が表示されたURLを登録しないならない。だから、このままIEで別タブを出して、そこに「Google」と入れて、Googleのサイトを出した。

http://www.google.co.jp/

ここで検索窓に大文字で TEST と入力して検索してみた。

なんちゅうこっちゃぁ〜〜〜〜あ。検索結果がいつまで経っても出てこない。つまり、早い話が、今使ってるVistaのIE7ではGoogleでの検索が出来ないちゅうこっちゃぁ〜〜〜〜あ!!!

既定の検索をLive Searchに切り替えてからやってみると、うまく行く。
すると、MSはIE7での検索エンジンをGoogleは登録する事が出来ても使えない設定にしてしまったのか? 
なんて疑い始めた。(ほんまかいなぁ?)

実際にGoogleの検索窓に 大文字で TEST と入れて検索した結果表示したURL
http://www.google.co.jp/search?hl=ja&q=TEST&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=

これをリンクにした物、こんな結果になる。
http://www.google.co.jp/search?hl=ja&q=TEST&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=

2:問題を解決する為にまずは、先の追加プロバイダの登録画面に戻して、そこのURLにこれを入れた。
http://www.google.co.jp/search?hl=ja&q=TEST&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=

そして、間違わないように 名前を「Google-2」としてみた


【結果】
●IEを一旦閉じて、再度起動してみた。
 クリックすると今までのなかなか起動しないのが嘘みたいに瞬時で起動してくる。
●検索エンジンがGoogle-2になってるの確認して何か検索してみた。
 これまた、あっとゆうまに検索結果が出る。

何が原因かは不明やけども、これで一応は修正出来た。


【余談】
このVistaのテスト機では、こうゆう不都合が出たけど、メインで使ってるVISTAでは全然問題なしに登録されている追加プロバイダから選んだGoogleでOKだ。

すると、このテスト機固有の何かのソフトとの相性なのか?テスト機と言うだけあって、メインのVistaで使う前にこれで問題が起きないかテストするから、そうゆう環境が問題を起こしてるのか?

これでIEでGoogle検索が可能になった。

どうしてこうなったかは不明。
IE7以外のブラウザではGoogle検索可能だし。
それにほかのPCではこの問題は起きてない。
環境に寄るのだろうと思う。


【IEではどうしても駄目な場合】

こうゆう方法でもOK。多分こっちの方がええと思う。

IEのサーチエンジンを追加で表示されているGoogleを選んで既存のサーチにするとこうなる。そこで新規に Google-2 というのを作ってそれを登録する。

IEに登録するには検索エンジンのサイトで 大文字で TEST という言葉で検索してその結果を表示してるURLを新規の検索サイトURLとして登録しないとならない。そこで次のようにする。

●別のブラウザでGoogleにとんだ
 Sleipnir でも FireFoxでも。
●そこで 検索窓に TEST と大文字で入力して検索
●その結果を表示してるUELをIEの検索エンジン登録URLに入力
●名前を Google-2 と入れて登録



【ネットで見つけた同じような問題】

■DonutPのGoogle検索バーが使えない人へ(ini全部更新)
http://kewl.jugem.cc/?eid=36

firefox で google検索が使えない
http://dospara.okwave.jp/qa4217253.html




【Home】   【日記メニュー】